NotePage, Inc. Forum Index

How to test SMS from Note Page

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> NotePager Pro Support
View previous topic :: View next topic  
Author Message
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 3:57 pm    Post subject: How to test SMS from Note Page Reply with quote

Hi,
I have Note Page configured with AT&T Tap.
I have recipients configured.
I'm trying to test outgoing SMS out. Is there a tool or set of commands that I can run to test this?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:02 pm    Post subject: Reply with quote

To test it, all you should need to do is click on the name of a Recipient in the Recipients list to move them over to the Selected Recipients list. Then type a message in the "Message Text" box and hit Send. The Connection Monitor will display the command and response sequence for the delivery attempt and will record whether or not the message was successful.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 4:08 pm    Post subject: Reply with quote

Ok. It seems that the connection to carrier is started, the connection using TAP is initiated, but the logs keep displaying Attempting to reset modem. Eventually the logs display Hanging up modem.

Obviously something is going on with the modem.
I'm assuming the modem is not starting or else it doesn't support this type of traffic?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:12 pm    Post subject: Reply with quote

It sounds like the program is referencing a COM port other than the one the modem is tied to. So, here's what you'll want to do:

1) Go in to the Control Panel in Windows.

2) Go to Phone and Modem.

3) Go under the Modems tab and make a note of the COM port the modem is tied to.

4) In NotePager Pro, go to Tools - Settings - Modem.

5) Set the "Modem Port" field to match the COM port of the modem.

6) Click on Apply and see if the same behavior is present.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 4:25 pm    Post subject: Reply with quote

The modem is connected on COM3. I confirmed this through Control Panel > Modems and also through device manager.
I also ran a modem scan in Note Page and confirmed that only COM3 is checked.

I queried the modem using the tool available in the modem properties and I get
ATQ0V1E0 Success

Iit recognizes the modem type.

AT#CLS=? is not supported

ATI2 Success



The logs in Note Page show first
Sent: AT<CR>
Attempting to reset modem.

This loops three times. Then it tries a different command
Sent: ATH0<CR>

Tries three times until it reaches the attempts limit.

So it looks like the modem answers when tested from Windows, but it doesn't answer when Note Page calls it.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:26 pm    Post subject: Reply with quote

What make and model of modem are you trying to use?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 4:29 pm    Post subject: Reply with quote

Zoom Technologies V.92
Series 0375

btw, in your previous post you mentioned Tools > Settings
but I couldn't really find those settings.


Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 4:38 pm    Post subject: Reply with quote

I'm also trying with a US Robotics 5633

Both are USB modems (a little old, but device/drivers are still recognized by Windows). Note that in both cases I'm loading drivers manually from manufacturer.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:43 pm    Post subject: Reply with quote

Wait, are you using PageGate or NotePager Pro? If you're using NotePager Pro, you should have a Tools menu with several options. If you're using PageGate and the PageGate client, that setting is in an entirely different location.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:44 pm    Post subject: Reply with quote

Also, I've never been able to get a Zoom modem to connect to a TAP system before. There's something about the chipset they use, and I don't know what it is, that just cannot handle handshaking with a TAP system. I would really recommend not using that modem, go with the USR modem.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 4:49 pm    Post subject: Reply with quote

My bad. I'm using PageGate.
Ok. I'm testing with the USR again.
Where's the tools > modem setting that you spoke of


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 4:53 pm    Post subject: Reply with quote

Ah, that makes more sense. Originally, I assumed you were using NotePager Pro since the thread was in the NPP portion of the forum.

Anyhow, what you'll want to do is open the PageGate Admin on the PageGate Server. Then:

1) Go to Connectors - Connector 1 - Settings.

2) Set the "Serial Port" field to match the COM port of the modem.

3) Make sure Direct Connect is NOT checked.

4) Click on Apply.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Fri Jan 24, 2014 5:12 pm    Post subject: Reply with quote

Ok. This looks better. It's initiating a connection but now I'm getting no response from the carrier. I'm checking with AT&T to determine if it's an issue on their end.

Btw, I see a service for PageGate Connector1 under Windows services.
Do I have to set that service to start automatically given that I linked the modem to Connector1 in the application?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jan 24, 2014 5:16 pm    Post subject: Reply with quote

What TAP number are you using? The best to use for AT&T is 18009094602.

As for the services, no. The only PageGate service that should have an Automatic startup type is the service named PageGate. Any sub-services (Scheduler, Connectors, Modules) are started in a very specific order controlled by the main PageGate service.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
modemhead



Joined: 03 Jan 2014
Posts: 18
Location: NY

PostPosted: Mon Feb 03, 2014 4:41 pm    Post subject: Reply with quote

The alternate ATT phone number that you provided seems to have done the trick. Will test further and report IF I have issues.


Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> NotePager Pro Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin