NotePage, Inc. Forum Index

ATT's SNPP

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> General Questions and Announcements
View previous topic :: View next topic  
Author Message
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Fri Jun 21, 2013 12:33 pm    Post subject: ATT's SNPP Reply with quote

I'm trying to send text messages using ATT's SNPP. I tested my server using telnet and it works but when I use Pagegate it fails because I need to enter username and password and I can't have both on my Carrier configuration. I'm using Pagegate 4.0


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jun 21, 2013 12:41 pm    Post subject: Reply with quote

The username and the password are required by AT&T to use their SNPP gateway. If you haven't registered with their gateway, you won't be granted access regardless.

Once you do get registered and receiver your username and password, however, you can go in to the Carrier settings and enter both the username and the password in to the password field, separated by a space.

ex; fguzman password here

Apply the settings and you should be done.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Fri Jun 21, 2013 12:54 pm    Post subject: Reply with quote

Thanks for the reply. I have a corporate username and password but they don't fit on the carrier configuration box. The username is 9 char long and the password is 10, when I typed them it only takes the first 10 characters. Is there a way to extend the limit of the field?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jun 21, 2013 1:00 pm    Post subject: Reply with quote

Unfortunately, there wasn't a way to do so in the interface of version 4. You can, however, manually edit the properties of the password field in the database and enter a value. Here's what you'll want to do:

1) Shut PageGate's processes and applications down. Make sure nothing else is accessing the database.

2) Browse in to the Database folder (typically c:\Program Files\PageGate\ for v4)

3) Open the pagegate.mdb file in MS Access.

4) Right click on the Carriers table and left click on Design View.

5) In the Design View, click on the password field and then in the Field Size field below, set the value to 100.

6) Then double click on the Carriers table on the left to open it.

7) In the line of your AT&T carrier, click in the password field and enter the username and password separated by a space.

8) Save and close the database.

9) Restart the PageGate Server.

Alternatively, you could upgrade to the most recent version of PageGate. We've made several interface improvements as well as better protocol version support for SNPP.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
OzCom



Joined: 22 Oct 2003
Posts: 1087
Location: US

PostPosted: Fri Jun 21, 2013 1:58 pm    Post subject: Reply with quote

You should also consider upgrading - you are 2 versions behind and there have been NUMEROUS enhancements and additions with the current v6.



_________________
Aaron D. Osgood
Streamline Communications, LLC
* Authorized Notepage, Inc. Development Partner and Re-seller
TEL: 207-518-8455
AOsgood@streamline-solutions.net
Creators of AutoPage Spillman CAD interface for PageGate
Back to top
View user's profile Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Fri Jun 21, 2013 1:59 pm    Post subject: Reply with quote

I changed the DBase. The log went further but it fail :

6/21/2013 2:49:52 PM Working on message to: zzz from: F. Guzman
6/21/2013 2:49:52 PM Formatting message
6/21/2013 2:49:52 PM Message contained in single packet
6/21/2013 2:49:52 PM Sending message
6/21/2013 2:49:52 PM Sent:LOGI username password
6/21/2013 2:49:53 PM Received:250 Login Accepted
6/21/2013 2:49:53 PM Login accepted
6/21/2013 2:49:53 PM Sent:PAGE 313xxxxxxx
6/21/2013 2:49:53 PM Received:250 Pager ID Accepted
6/21/2013 2:49:53 PM Sent:DATA
6/21/2013 2:50:33 PM No Response
6/21/2013 2:50:33 PM Sent:MESS test
6/21/2013 2:50:33 PM Disconnected
6/21/2013 2:50:33 PM Message not accepted
6/21/2013 2:50:33 PM Message retry limit reached
6/21/2013 2:50:33 PM FAILED Stn:10 To:zzz Frm:F. Guzman Msg:test
6/21/2013 2:50:33 PM Disconnected from server
6/21/2013 2:50:33 PM Carrier retry limit reached. Marking pending messages as bad

The only thing I noticed is that when I use telnet, I go
LOGIn
PAGE
MESS
SEND
QUIT.

In the log we sent DATA before MESS.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jun 21, 2013 2:01 pm    Post subject: Reply with quote

As OzCom posted, I'd really recommend upgrading PageGate. Version 4 didn't have the same protocol support that version 6 does.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Fri Jun 21, 2013 2:17 pm    Post subject: Reply with quote

OK, I will upgrade. Thank you for your help.


Back to top
View user's profile
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Wed Jun 26, 2013 10:03 am    Post subject: Reply with quote

6/26/2013 10:31:34 AM Module Started
6/26/2013 10:31:36 AM Time synchronized with scheduler
6/26/2013 10:40:26 AM ========================================
6/26/2013 10:40:26 AM Start connection to carrier: ATT
6/26/2013 10:40:26 AM Connect using SNPP protocol
6/26/2013 10:40:27 AM Connected to Host (198.24.14.45:444)
6/26/2013 10:40:27 AM Received:220 (V3) Gateway Ready<13><10>
6/26/2013 10:40:27 AM SNPP Session Started
6/26/2013 10:40:27 AM ----------------------------------------
6/26/2013 10:40:27 AM Working on message to: zzz from: F. Guzman
6/26/2013 10:40:27 AM Formatting message
6/26/2013 10:40:27 AM Message contained in single packet
6/26/2013 10:40:27 AM Sending message
6/26/2013 10:40:27 AM Sent:LOGI xxxxx yyyyy<13><10>
6/26/2013 10:40:27 AM Received:250 Login Accepted<13><10>
6/26/2013 10:40:27 AM Login accepted
6/26/2013 10:40:27 AM Sent:PAGE 313zzzzzz<13><10>
6/26/2013 10:40:28 AM Received:250 Pager ID Accepted<13><10>
6/26/2013 10:40:28 AM Sent:DATA<13><10>
6/26/2013 10:40:58 AM No Response
6/26/2013 10:40:58 AM Sent:MESS test<13><10>
6/26/2013 10:40:58 AM Disconnected
6/26/2013 10:40:58 AM Message not accepted
6/26/2013 10:40:58 AM Failed Attempt Stn:10 To:zzz Frm:F. Guzman Msg:test
6/26/2013 10:40:58 AM Disconnected from server


Back to top
View user's profile
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Wed Jun 26, 2013 10:04 am    Post subject: Reply with quote

I update the system to 6 and still have the same problem.
I crashed on the DATA command, Ithink


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Wed Jun 26, 2013 10:10 am    Post subject: Reply with quote

You may want to contact AT&T about this. What's happening is that the credentials are being accepted but when the program issues the DATA command, we're not receiving a response, so we're failing over to the MESS command but we still don't receive a response and eventually time out the connection. I don't know why we aren't receiving a response from the AT&T host.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
fguzman



Joined: 21 Jun 2013
Posts: 7

PostPosted: Wed Jun 26, 2013 10:15 am    Post subject: Reply with quote

I have a document from AT&T called
AT&T Developer Program
Enterprise Paging
Troubleshooting Guide

In that document they have a reference with the following sequence:
LOGIn
PAGE
MESS
SEND
QUIT

When I follow it, using telnet, from the same server I have PageGate. It goes thru. Is there a way to avid sending DATA before MESS?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Wed Jun 26, 2013 11:40 am    Post subject: Reply with quote

PageGate uses the DATA command because it is more flexible in what can be sent as message content. However, as you can see in your log, if the DATA command isn't accepted PageGate will fall back to trying the MESS command.

I tested AT&T's 'regular' snpp gateway (snpp.att.net) and it doesn't have any problem with the DATA command.

I think you should contact AT&T, because if they aren't accepting the DATA command, then there is most likely a problem on their end.

Be sure to send them the log so they can see the problem.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> General Questions and Announcements All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin