NotePage, Inc. Forum Index

Cannot start pagegate service

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support
View previous topic :: View next topic  
Author Message
dpotter



Joined: 29 Sep 2015
Posts: 7

PostPosted: Tue Sep 29, 2015 11:11 am    Post subject: Cannot start pagegate service Reply with quote

Just downloaded and installed pg7setup.exe on a windows 7 computer and ran the server install and then ran pgadmin as an admin let it create the DB, log, and archive directories and create a new DB, I then changed the setting in pgadmin to run as a windows service. But the Pagegate service will not start, I keep getting the Error 1053: The service did not respond to the start or control request in a timely fashion.

Any assistance would be greatly apprectiated.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Tue Sep 29, 2015 11:18 am    Post subject: Reply with quote

Do you have any of the PageGate folders (i.e. database, log, program, archive) setup for any drive other than the c: drive?

The standard Windows System Service account that is used by PageGate by default may not have sufficient access to anything other than c:

When you switched PageGate over to run as a service, did you leave the credentials blank to use the standard system service, or did you enter credentials for your own account?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpotter



Joined: 29 Sep 2015
Posts: 7

PostPosted: Tue Sep 29, 2015 3:23 pm    Post subject: Reply with quote

Yes the PageGate folders are on a network drive. I tried both leaving the credentials blank and my credentials, neither worked. Same error. Also even thought the error message would imply there was a delay, the error message comes up long before the 30 second default. But I went ahead and tried adding the ServicesPipeTimeout=180000 per Microsoft article, didn't help.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Tue Sep 29, 2015 4:36 pm    Post subject: Reply with quote

Can you try moving the PageGate program and data folder to the local c-drive? Or is that not possible at your location?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpotter



Joined: 29 Sep 2015
Posts: 7

PostPosted: Wed Sep 30, 2015 7:35 am    Post subject: Reply with quote

As a test, I did a reinstall with all local and it seems to have worked fine. The account that I was using had full rights to the network share and was a member of the local computer administrator group and I had granted the account permission to "log on as a service". Do you have any idea what permission that account could have been missing to have caused this issue. We would really prefer that the DB reside on a network share for back up reasons.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Wed Sep 30, 2015 7:42 am    Post subject: Reply with quote

Those sound like all the correct permissions for PageGate to run with a 'custom' account.

Sometimes working at it from a different angle can help. Try these steps:

1. Switch PageGate back to run as an application and verify that it is all up and running (and no PageGate services left)

2. Stop PageGate

3. Log out of the computer and log back in using the 'custom' account you have created.

4. Start PageGate and make sure it is all running correctly as an application (this will help check the rights of the user account)

5. With PageGate running, switch it to run as a service, leaving the credentials blank - it probably won't be able to start back up.

6. Go to the Windows Services Manager through the Windows Control Panel

7. Right-click on each of the PageGate services and choose 'Properties'. Change the user account that the PageGate services are set to use to your 'custom' user account.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpotter



Joined: 29 Sep 2015
Posts: 7

PostPosted: Fri Oct 02, 2015 1:50 pm    Post subject: Reply with quote

I tried you suggestion. I can get it to run as a service if the DB is local on the C drive, or I can get it to run as an application with the DB on the network share but I cannot get it to run as a service with the DB on a network share. As a service with DB on a network share is how we have been running Pagegate for quite some time, but with this version 7 on windows 7, I don't seem to be able to. I get a message when it tries to start the service that the DB cannot be located. Any suggestions?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Oct 02, 2015 2:09 pm    Post subject: Reply with quote

In PG Admin when you go to Program->Settings and view the folder locations, do the folder locations for the networked drive use a mapped drive letter or a full UNC path. If you are using drive letters, then that is the problem. Drive letters are only assigned when a user logs in and are not available to system services.

So if you are using mapped drive letters, change them to use UNC paths instead.

If that is not the problem, then please post back and we will keep working on your problem.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpotter



Joined: 29 Sep 2015
Posts: 7

PostPosted: Fri Oct 09, 2015 11:41 am    Post subject: Reply with quote

I finally got it to run as a service. Thank you for all your help.


Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin