NotePage, Inc. Forum Index

Errors: 94, 310, and 'time unable to sync with scheduler'

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support
View previous topic :: View next topic  
Author Message
Adm1n



Joined: 21 Nov 2014
Posts: 4
Location: Austin, TX

PostPosted: Fri Nov 21, 2014 2:08 pm    Post subject: Errors: 94, 310, and 'time unable to sync with scheduler' Reply with quote

Looking for a fix - got multiple issues going on simultaneously and it's all just a headache.

Issue #1: pages start failing; Error: 'time unable to sync with scheduler'; reset 'windows time service' - nothing. Confirmed local server time is synced and accurate.

Issue #2: Error #94: Invalid use of Null in Procedure: SendGSM; my notes say this is most likely from a malformed line in the database, but when I checked the contents of the database I found no such line.

Issue #3: +CMS Error: 310; strikes randomly but brings things to a screeching halt. Usually requires power cycling of device and server to get it back up and going.


The failures are happening more often and costing the business a lot in downtime. The failure scenario encountered last night (at midnight >.<) started with issue #3 - no discernible explanation as to why the error occurred. Logs look normal. After querying the modem in device manager and getting positive results I tried running through my putty reset procedure. When it came back online I started seeing issue #2. When I got to the datacenter and did a hard reset on the device, I then encountered issue #1. (... yes, I feel like I numbered those in reverse.)

I finally shutdown the server completely, unplugged the usb modem (which power cycled it), then brought both devices back online. Opened the Pagegate Monitor and saw the user side texts 'flying'. When I attempted to send a test text from Pagegate Admin I got the 'error 94: 'time unable to sync with scheduler'. I left it alone out of fear of breaking it again and causing more downtime.

Any ideas or thoughts on what to look at and/or fix would be most appreciated.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Nov 21, 2014 2:15 pm    Post subject: Reply with quote

The "unable to synchronize time with scheduler" message indicates that the PageGate Scheduler service has been stopped, likely due to the Error #94 you're receiving. There's some information we need to gather, though.

Go in to the PageGate program directory on the hard drive and go in to the properties of the pagegate.exe file. What file version of PageGate are you using?

Also, what operating system are you using?

If you would, please email the c:\PageGateData\Logs\*.log files to support at notepage dot com so we can take a look at the errors in context.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Adm1n



Joined: 21 Nov 2014
Posts: 4
Location: Austin, TX

PostPosted: Fri Nov 21, 2014 2:23 pm    Post subject: Reply with quote

Tech Support wrote:
The "unable to synchronize time with scheduler" message indicates that the PageGate Scheduler service has been stopped, likely due to the Error #94 you're receiving. There's some information we need to gather, though.
Except I confirmed that all services were running at the time - so while that seems sensible, something doesn't quite add up.


Tech Support wrote:
Go in to the PageGate program directory on the hard drive and go in to the properties of the pagegate.exe file. What file version of PageGate are you using?
Version is 5.1.0.6

Tech Support wrote:
Also, what operating system are you using?
Server 2008 R2 Standard

Tech Support wrote:
If you would, please email the c:\PageGateData\Logs\*.log files to support at notepage dot com so we can take a look at the errors in context.
Sent.

Thanks ahead of time.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Nov 21, 2014 2:39 pm    Post subject: Reply with quote

With regards to the CMS 310 error you're receiving, that's a hardware issue as the error means "SIM not inserted".



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Adm1n



Joined: 21 Nov 2014
Posts: 4
Location: Austin, TX

PostPosted: Fri Nov 21, 2014 2:47 pm    Post subject: Reply with quote

Tech Support wrote:
With regards to the CMS 310 error you're receiving, that's a hardware issue as the error means "SIM not inserted".


Is there a command that I can issue to the device via putty to confirm whether it's the device or the software? When I run the device manager modem query routine I get the following:

ATQ0V1E0 - OK
AT+GMM - HE910-D
AT+FCLASS=? - (0,8)
AT#CLS=? - COMMAND NOT SUPPORTED
AT+GCI? - +GCI: 59
AT+GCI=? - +GCI: (59)
ATI1 - 0
ATI2 - OK
ATI3 - Telit
ATI4 - HE910-D
ATI5 - DOB v.2.0
ATI6 - COMMAND NOT SUPPORTED
ATI7 - COMMAND NOT SUPPORTED

Any of this confirm that a SIM is being seen?

Sidenote: I never reseated the SIM during my re-initialization of the system.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Nov 21, 2014 2:56 pm    Post subject: Reply with quote

No, the local modem query commands just indicate that the hardware is present and functioning. You would need to run Hyperterminal, Putty, VBTerm or a similar port testing utility, then establish a connection with the modem's COM port at:
115200 baud
8 data bits
1 stop bit
No parity

Then issue the following commands in sequence:

AT
AT+CSQ
AT+CMGF=1
AT+CMGS="cellphonenumber"

If the command sequence reaches that far without error, it indicates that the SIM is being read properly.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Adm1n



Joined: 21 Nov 2014
Posts: 4
Location: Austin, TX

PostPosted: Fri Nov 21, 2014 4:05 pm    Post subject: Reply with quote

Great - new info - thanks much. I've been using the putty session to access the device but have only been using the following commands:

auto reset (usually fails):
at!reset

manual reset (has had no affect on the failure):
at+cfun=0
at+cfun=1



Secondary Questions that just arose:
- Is there a USB based SMS modem that you guys (@ Pagegate) recommend that's been a 'tried and true' workhorse (and that the drivers are compatible and stable with our OS)?
- Does Pagegate support multiple modems? for failover or load balancing?
-- If so, will running multiple modems increase stability of the overall system?


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Mon Nov 24, 2014 10:26 am    Post subject: Reply with quote

Apologies for the delay in getting back with you, I wanted to verify with the Development Team before I made our recommendations. Issues 1 and 2 in your original post have been resolved in the latest version of PageGate, so I would recommend upgrading to version 7. That should take care of things.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
OzCom



Joined: 22 Oct 2003
Posts: 1087
Location: US

PostPosted: Mon Nov 24, 2014 10:41 am    Post subject: Reply with quote

We recommend MultiTech brand devices. We prefer RS-232 Serial over USB due to the known MS Windows USB-COMport driver issues, but have installed hundreds of USB in North America. We have tried numerous other devices and the MultiTech ones are the only ones we have found to be basically bulletproof.

PageGate, with the proper optional license keys, can drive up to 16 of these devices and load balance across them all



_________________
Aaron D. Osgood
Streamline Communications, LLC
* Authorized Notepage, Inc. Development Partner and Re-seller
TEL: 207-518-8455
AOsgood@streamline-solutions.net
Creators of AutoPage Spillman CAD interface for PageGate
Back to top
View user's profile Send e-mail Visit poster's website AIM Address Yahoo Messenger MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin