NotePage, Inc. Forum Index

TAP Problems

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support
View previous topic :: View next topic  
Author Message
dpellerin



Joined: 14 Jan 2004
Posts: 22

PostPosted: Tue Nov 07, 2006 1:58 pm    Post subject: TAP Problems Reply with quote

We've been experiencing a situation where the system will fail to send TAP pages and requires us to reset the modem to correct.

I spoke to the technicians at our paging provider, and they think that something in the conversation between systems is getting out of sync. They say that when this happens, their system will send an <EOT> to reset the conversation per the protocol spec (according to them). However, PageGate ignores this and continues to send <ESC>PG1<CR>. So the connection is never reset and we have to manually drop the line so PageGate will reset.

I'm pasting in a portion of our logs so you can see what's happening. I don't pretend to understand the subtleties of the TAP protocol, but maybe this will shed some light on what's happening, and more importantly, how to fix! The first entry here is a successful page, then the problem starts and you can see two failures to negotiate. This will continue until we power cycle the modem.

Thanks in advance for any light you can shed on our issue.

Dana

-----------------------------------------------------------

11/2/2006 12:16:38 AM Sent:<EOT><CR>
11/2/2006 1:19:22 AM ========================================
11/2/2006 1:19:22 AM Start connection to carrier: Metrocall-TAP
11/2/2006 1:19:22 AM Connect using TAP protocol
11/2/2006 1:19:22 AM Setting communication parameters
11/2/2006 1:19:22 AM Connected to carrier
11/2/2006 1:19:22 AM Waiting for protocol initialization
11/2/2006 1:19:22 AM Sent:<CR>
11/2/2006 1:19:26 AM Sent:<CR>
11/2/2006 1:19:26 AM Received:ID=<LF><CR>
11/2/2006 1:19:26 AM TAP protocol detected
11/2/2006 1:19:27 AM Sent:<ESC>PG1<CR>
11/2/2006 1:19:28 AM Received:<ACK><CR>
11/2/2006 1:19:28 AM Received:<ACK><CR><ESC>[p<CR>
11/2/2006 1:19:28 AM Automatic TAP mode accepted
11/2/2006 1:19:28 AM ----------------------------------------
11/2/2006 1:19:28 AM Working on message to: CRMCEDEKG from: TCC1EMD24984
11/2/2006 1:19:28 AM Formatting message
11/2/2006 1:19:28 AM Message contained in single packet
11/2/2006 1:19:28 AM Message contained in single block
11/2/2006 1:19:28 AM Sending block
11/2/2006 1:19:28 AM Sent:<STX>1234567<CR>1242:TCC1EMD24984:WE NEED A xxxx TO xxxx PLS<CR><ETX>;<1<CR>
11/2/2006 1:19:29 AM Received:<ACK><CR>
11/2/2006 1:19:29 AM Block sent successfully
11/2/2006 1:19:29 AM Packet sent successfully
11/2/2006 1:19:29 AM SUCCESSFUL Stn:1 To:CRMCEDEKG Frm:TCC1EMD24984 File:fcfabdcb-46c9-489d-8f9f-6f27270ef7f6.630 Msg:WE NEED A xxxx TO xxxx PLS

11/2/2006 1:19:29 AM Sent:<EOT><CR>
11/2/2006 1:52:21 AM ========================================
11/2/2006 1:52:21 AM Start connection to carrier: Metrocall-TAP
11/2/2006 1:52:21 AM Connect using TAP protocol
11/2/2006 1:52:21 AM Setting communication parameters
11/2/2006 1:52:21 AM Connected to carrier
11/2/2006 1:52:21 AM Waiting for protocol initialization
11/2/2006 1:52:21 AM Sent:<CR>
11/2/2006 1:52:24 AM Received:<17>
11/2/2006 1:52:24 AM Sent:<CR>
11/2/2006 1:52:26 AM Received:ID=<LF><CR>ID=<LF><CR>
11/2/2006 1:52:26 AM TAP protocol detected
11/2/2006 1:52:27 AM Sent:<ESC>PG1<CR>
11/2/2006 1:52:37 AM Received:ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>
11/2/2006 1:52:37 AM Sent:<ESC>PG1<CR>
11/2/2006 1:52:48 AM Received:ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>
11/2/2006 1:52:48 AM Sent:<ESC>PG1<CR>
11/2/2006 1:53:03 AM ========================================
11/2/2006 1:53:03 AM Start connection to carrier: Metrocall-TAP
11/2/2006 1:53:03 AM Connect using TAP protocol
11/2/2006 1:53:03 AM Setting communication parameters
11/2/2006 1:53:03 AM Connected to carrier
11/2/2006 1:53:03 AM Waiting for protocol initialization
11/2/2006 1:53:03 AM Sent:<CR>
11/2/2006 1:53:06 AM Sent:<CR>
11/2/2006 1:53:11 AM Sent:<CR>
11/2/2006 1:53:14 AM Received:ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>
11/2/2006 1:53:14 AM TAP protocol detected
11/2/2006 1:53:14 AM Sent:<ESC>PG1<CR>
11/2/2006 1:53:25 AM Received:ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>
11/2/2006 1:53:25 AM Sent:<ESC>PG1<CR>
11/2/2006 1:53:35 AM Sent:<ESC>PG1<CR>
11/2/2006 1:53:46 AM Received:ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR>ID=<LF><CR><ESC><EOT><CR>


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4243

PostPosted: Tue Nov 07, 2006 2:19 pm    Post subject: Reply with quote

What is the make and model of the model you're using and does it connect via serial or USB?

Also, what version of Windows are you using?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpellerin



Joined: 14 Jan 2004
Posts: 22

PostPosted: Tue Nov 07, 2006 2:53 pm    Post subject: Reply with quote

It's a Motorola UDS v.3229. We're on a 9600 baud leased line. It's connected to a standard rs-232 serial port. And we are running Windows 2003 SP1.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4243

PostPosted: Tue Nov 07, 2006 3:33 pm    Post subject: Reply with quote

I've seen this happen with other modems before and, in the end, it ended up being the driver. The last time I saw this was with a US Robotics modem, though, not a Motorola UDS. We eventually found out that there was no Server 2003 driver for the modem and that 2003 didn't really like the driver that it was given.

From the searching I've done, which has been relatively limited so far, it loks like this may also be the case with the Motorola UDS v3229. Admittely, Motorola doesn't make their support site the easiest in the world to use.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
dpellerin



Joined: 14 Jan 2004
Posts: 22

PostPosted: Tue Nov 07, 2006 4:32 pm    Post subject: Reply with quote

Well, I guess I could always find another modem and give that a shot.

Do you guys have a list of modems you've had good experience with?

Dana


Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin