NotePage, Inc. Forum Index

New MTC-LNA4-B03 MultiTech Modem not working

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support
View previous topic :: View next topic  
Author Message
mcguffin



Joined: 08 Nov 2019
Posts: 4
Location: Oak Ridge, TN

PostPosted: Fri Nov 08, 2019 10:47 am    Post subject: New MTC-LNA4-B03 MultiTech Modem not working Reply with quote

I just upgraded to this modem and am having an issue sending text messages. Log file shows the following:

11/8/2019 10:38:14 AM ========================================
11/8/2019 10:38:14 AM Start connection to carrier: Verizon-cell
11/8/2019 10:38:14 AM Connect using GSM protocol
11/8/2019 10:38:14 AM Setting communication parameters (115200,n,8,1)
11/8/2019 10:38:15 AM Received:<ESC><CR>
11/8/2019 10:38:15 AM Attempting to reset modem
11/8/2019 10:38:15 AM Sent:AT<CR>
11/8/2019 10:38:15 AM Received:AT<CR><CR><LF>OK<CR><LF>
11/8/2019 10:38:15 AM Modem reset
11/8/2019 10:38:15 AM Attempting to send connector init string
11/8/2019 10:38:15 AM Sent:AT+CSQ<CR>
11/8/2019 10:38:15 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:38:15 AM connector init string sent
11/8/2019 10:38:15 AM Attempting to send carrier init string
11/8/2019 10:38:15 AM Sent:AT+CSQ<CR>
11/8/2019 10:38:15 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:38:15 AM Carrier init string sent
11/8/2019 10:38:15 AM Sent:AT+WSCL=1,2<CR>
11/8/2019 10:38:16 AM Received:AT+WSCL=1,2<CR><CR><LF>ERROR<CR><LF>
11/8/2019 10:38:16 AM Not supported... continuing
11/8/2019 10:38:16 AM ----------------------------------------
11/8/2019 10:38:16 AM Working on message to: mikemcguffin-cell from: PageGate
11/8/2019 10:38:16 AM Formatting message
11/8/2019 10:38:16 AM Message contained in a single packet
11/8/2019 10:38:16 AM Sending packet
11/8/2019 10:38:16 AM Sent:AT+CMGS="8659514464"<CR>
11/8/2019 10:38:16 AM Received:AT+CMGS="8659514464"<CR><CR><LF>>
11/8/2019 10:38:16 AM Sent:PageGate:Testing123<SUB>
11/8/2019 10:38:16 AM Received:PageGate:Testing123<SUB><CR><LF>+CMS ERROR: 111<CR><LF>
11/8/2019 10:38:16 AM Error sending packet
11/8/2019 10:38:16 AM Sent:<ESC><CR>
11/8/2019 10:38:52 AM ========================================
11/8/2019 10:38:52 AM Start connection to carrier: Verizon-cell
11/8/2019 10:38:52 AM Connect using GSM protocol
11/8/2019 10:38:52 AM Setting communication parameters (115200,n,8,1)
11/8/2019 10:38:52 AM Received:<ESC><CR>
11/8/2019 10:38:52 AM Attempting to reset modem
11/8/2019 10:38:52 AM Sent:AT<CR>
11/8/2019 10:38:53 AM Received:AT<CR><CR><LF>OK<CR><LF>
11/8/2019 10:38:53 AM Modem reset
11/8/2019 10:38:53 AM Attempting to send connector init string
11/8/2019 10:38:53 AM Sent:AT+CSQ<CR>
11/8/2019 10:38:53 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:38:53 AM connector init string sent
11/8/2019 10:38:53 AM Attempting to send carrier init string
11/8/2019 10:38:53 AM Sent:AT+CSQ<CR>
11/8/2019 10:38:53 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:38:53 AM Carrier init string sent
11/8/2019 10:38:53 AM Sent:AT+WSCL=1,2<CR>
11/8/2019 10:38:53 AM Received:AT+WSCL=1,2<CR><CR><LF>ERROR<CR><LF>
11/8/2019 10:38:53 AM Not supported... continuing
11/8/2019 10:38:53 AM ----------------------------------------
11/8/2019 10:38:53 AM Working on message to: mikemcguffin-cell from: PageGate
11/8/2019 10:38:53 AM Formatting message
11/8/2019 10:38:53 AM Message contained in a single packet
11/8/2019 10:38:53 AM Sending packet
11/8/2019 10:38:53 AM Sent:AT+CMGS="8659514464"<CR>
11/8/2019 10:38:53 AM Received:AT+CMGS="8659514464"<CR><CR><LF>>
11/8/2019 10:38:53 AM Sent:PageGate:Testing123<SUB>
11/8/2019 10:38:54 AM Received:PageGate:Testing123<SUB><CR><LF>+CMS ERROR: 111<CR><LF>
11/8/2019 10:38:54 AM Error sending packet
11/8/2019 10:38:54 AM Sent:<ESC><CR>
11/8/2019 10:39:30 AM ========================================
11/8/2019 10:39:30 AM Start connection to carrier: Verizon-cell
11/8/2019 10:39:30 AM Connect using GSM protocol
11/8/2019 10:39:30 AM Setting communication parameters (115200,n,8,1)
11/8/2019 10:39:30 AM Received:<ESC><CR>
11/8/2019 10:39:30 AM Attempting to reset modem
11/8/2019 10:39:30 AM Sent:AT<CR>
11/8/2019 10:39:30 AM Received:AT<CR><CR><LF>OK<CR><LF>
11/8/2019 10:39:30 AM Modem reset
11/8/2019 10:39:30 AM Attempting to send connector init string
11/8/2019 10:39:30 AM Sent:AT+CSQ<CR>
11/8/2019 10:39:30 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:39:30 AM connector init string sent
11/8/2019 10:39:30 AM Attempting to send carrier init string
11/8/2019 10:39:30 AM Sent:AT+CSQ<CR>
11/8/2019 10:39:31 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:39:31 AM Carrier init string sent
11/8/2019 10:39:31 AM Sent:AT+WSCL=1,2<CR>
11/8/2019 10:39:31 AM Received:AT+WSCL=1,2<CR><CR><LF>ERROR<CR><LF>
11/8/2019 10:39:31 AM Not supported... continuing
11/8/2019 10:39:31 AM ----------------------------------------
11/8/2019 10:39:31 AM Working on message to: mikemcguffin-cell from: PageGate
11/8/2019 10:39:31 AM Formatting message
11/8/2019 10:39:31 AM Message contained in a single packet
11/8/2019 10:39:31 AM Sending packet
11/8/2019 10:39:31 AM Sent:AT+CMGS="8659514464"<CR>
11/8/2019 10:39:31 AM Received:AT+CMGS="8659514464"<CR><CR><LF>>
11/8/2019 10:39:31 AM Sent:PageGate:Testing123<SUB>
11/8/2019 10:39:31 AM Received:PageGate:Testing123<SUB><CR><LF>+CMS ERROR: 111<CR><LF>
11/8/2019 10:39:31 AM Error sending packet
11/8/2019 10:39:31 AM Sent:<ESC><CR>
11/8/2019 10:40:07 AM ========================================
11/8/2019 10:40:07 AM Start connection to carrier: Verizon-cell
11/8/2019 10:40:07 AM Connect using GSM protocol
11/8/2019 10:40:07 AM Setting communication parameters (115200,n,8,1)
11/8/2019 10:40:08 AM Received:<ESC><CR>
11/8/2019 10:40:08 AM Attempting to reset modem
11/8/2019 10:40:08 AM Sent:AT<CR>
11/8/2019 10:40:08 AM Received:AT<CR><CR><LF>OK<CR><LF>
11/8/2019 10:40:08 AM Modem reset
11/8/2019 10:40:08 AM Attempting to send connector init string
11/8/2019 10:40:08 AM Sent:AT+CSQ<CR>
11/8/2019 10:40:08 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:40:08 AM connector init string sent
11/8/2019 10:40:08 AM Attempting to send carrier init string
11/8/2019 10:40:08 AM Sent:AT+CSQ<CR>
11/8/2019 10:40:08 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 26,4<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 10:40:08 AM Carrier init string sent
11/8/2019 10:40:08 AM Sent:AT+WSCL=1,2<CR>
11/8/2019 10:40:09 AM Received:AT+WSCL=1,2<CR><CR><LF>ERROR<CR><LF>
11/8/2019 10:40:09 AM Not supported... continuing
11/8/2019 10:40:09 AM ----------------------------------------
11/8/2019 10:40:09 AM Working on message to: mikemcguffin-cell from: PageGate
11/8/2019 10:40:09 AM Formatting message
11/8/2019 10:40:09 AM Message contained in a single packet
11/8/2019 10:40:09 AM Sending packet
11/8/2019 10:40:09 AM Sent:AT+CMGS="8659514464"<CR>
11/8/2019 10:40:09 AM Received:AT+CMGS="8659514464"<CR><CR><LF>>
11/8/2019 10:40:09 AM Sent:PageGate:Testing123<SUB>
11/8/2019 10:40:09 AM Received:PageGate:Testing123<SUB><CR><LF>+CMS ERROR: 111<CR><LF>
11/8/2019 10:40:09 AM Error sending packet
11/8/2019 10:40:09 AM Sent:<ESC><CR>
11/8/2019 10:40:10 AM Message retry limit reached
11/8/2019 10:40:10 AM FAILED Stn:0 To:mikemcguffin-cell Frm:PageGate DB Msg:Testing123 Sent Msg:PageGate:Testing123
11/8/2019 10:40:10 AM Carrier retry limit reached. Marking pending messages as bad

I have tried a couple of different init settings but nothing seems to work. Any ideas?

Thanks,
Mike McGuffin


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4206

PostPosted: Fri Nov 08, 2019 11:04 am    Post subject: Reply with quote

It's not an issue with the initialization string, the device is reporting a +CMS Error: 111, which is an unspecified protocol error.

Just to double check, whose carrier service are you trying to use that device with?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
mcguffin



Joined: 08 Nov 2019
Posts: 4
Location: Oak Ridge, TN

PostPosted: Fri Nov 08, 2019 11:13 am    Post subject: Reply with quote

We use Verizon for our carrier.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4206

PostPosted: Fri Nov 08, 2019 11:17 am    Post subject: Reply with quote

The LNA4's cellular radio has dual firmware and the factory settings default the device to AT&T's connection method.

To check that your device is configured for the desired network, run Putty and establish a connection with the device, then issue the following command:
AT#FWSWITCH?

If response is: #FWSWITCH: 0 The device is configured for AT&T/other
networks.

If response is: #FWSWITCH: 1 The device is configured for Verizon.

To switch carrier networks:
From AT&T to Verizon:
AT#FWSWITCH=1,1



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
mcguffin



Joined: 08 Nov 2019
Posts: 4
Location: Oak Ridge, TN

PostPosted: Fri Nov 08, 2019 11:24 am    Post subject: Reply with quote

Ran the command to change over to Verizon network successfully. Still doesn't send and now get the following:
11/8/2019 11:22:40 AM ========================================
11/8/2019 11:22:40 AM Start connection to carrier: Verizon-cell
11/8/2019 11:22:40 AM Connect using GSM protocol
11/8/2019 11:22:40 AM Setting communication parameters (115200,n,8,1)
11/8/2019 11:22:41 AM Received:<ESC><CR><CR><LF>#OMADM: "UIE_SESSION_STATE_NOTIFY_UI","DM","Complete","0"<CR><LF>
11/8/2019 11:22:41 AM Attempting to reset modem
11/8/2019 11:22:41 AM Sent:AT<CR>
11/8/2019 11:22:41 AM Received:AT<CR><CR><LF>OK<CR><LF>
11/8/2019 11:22:41 AM Modem reset
11/8/2019 11:22:41 AM Attempting to send connector init string
11/8/2019 11:22:41 AM Sent:AT+CSQ<CR>
11/8/2019 11:22:41 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 27,3<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 11:22:41 AM connector init string sent
11/8/2019 11:22:41 AM Attempting to send carrier init string
11/8/2019 11:22:41 AM Sent:AT+CSQ<CR>
11/8/2019 11:22:41 AM Received:AT+CSQ<CR><CR><LF>+CSQ: 27,3<CR><LF><CR><LF>OK<CR><LF>
11/8/2019 11:22:41 AM Carrier init string sent
11/8/2019 11:22:41 AM Sent:AT+WSCL=1,2<CR>
11/8/2019 11:22:42 AM Received:AT+WSCL=1,2<CR><CR><LF>ERROR<CR><LF>
11/8/2019 11:22:42 AM Not supported... continuing
11/8/2019 11:22:42 AM ----------------------------------------
11/8/2019 11:22:42 AM Working on message to: mikemcguffin-cell from: PageGate
11/8/2019 11:22:42 AM Formatting message
11/8/2019 11:22:42 AM Message contained in a single packet
11/8/2019 11:22:42 AM Sending packet
11/8/2019 11:22:42 AM Sent:AT+CMGS="8659514464"<CR>
11/8/2019 11:22:42 AM Received:AT+CMGS="8659514464"<CR><CR><LF>ERROR<CR><LF>
11/8/2019 11:22:42 AM Error sending packet
11/8/2019 11:22:42 AM Sent:<ESC><CR>
11/8/2019 11:22:43 AM Message retry limit reached
11/8/2019 11:22:43 AM FAILED Stn:0 To:mikemcguffin-cell Frm:PageGate DB Msg:Testing again.... Sent Msg:PageGate:Testing again....
11/8/2019 11:22:43 AM Carrier retry limit reached. Marking pending messages as bad


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4206

PostPosted: Fri Nov 08, 2019 11:32 am    Post subject: Reply with quote

Based on what I can see, it looks like PageGate isn't using the right AT command to enter SMS delivery mode. It looks like you're using:
AT+WSCL=1,2

and that should be:
AT+CMGF=1

If you would, go in to the Connectors - Connector 1 - Template section and specify the following variables in the 'Settings' section:
GSMUseCmgf = True
GSMUseCmgs = True
InterMessageDelay = 1000

If any other variables are specified there, please remove them.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
mcguffin



Joined: 08 Nov 2019
Posts: 4
Location: Oak Ridge, TN

PostPosted: Fri Nov 08, 2019 12:30 pm    Post subject: Reply with quote

We have a bingo!

Previous settings:
GSMUseCmgf = False
GSMUseWscl = True
GSMUseCmgs = True
GSMUseGT = True

New Settings:
GSMUseCmgf = True
GSMUseCmgs = True
InterMessageDelay = 1000

Successfully sent message to me.

Thanks for the assistance.


Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> PageGate Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin