NotePage, Inc. Forum Index

Can't program "senders name".

 
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> NotePager Pro Support
View previous topic :: View next topic  
Author Message
ahargrove



Joined: 16 Jul 2009
Posts: 1

PostPosted: Thu Jul 16, 2009 9:17 pm    Post subject: Can't program "senders name". Reply with quote

When I.T. installed NotePager Pro 3.0, it apparently had #LoginName# in the "senders name" field. I don't know if that's the default, but now I can't change it, even though I have Admin rights within the program itself. I've tried changing it from the wizard and from the general setup screen, and checking the "save settings for all users", but if I close it down and start it back up, the "#Login Name# is right back again. We defintely need it to say our departments dispatch name instead of the dispatchers login name. My only thought at this point is to ask I.T. to uninstall the software and reinstall it again, making the change during the install process, if that's possible. Thanks for any help you can send this way.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Fri Jul 17, 2009 8:38 am    Post subject: Reply with quote

The reason it keeps resetting is that the user you're logged into Windows as doesn't have permission to write to the global registry. If you log out and log back in as one of the Administrators and then make the change, it should apply it for all users and keep the setting.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
murraye



Joined: 14 Feb 2013
Posts: 5
Location: Pittsburgh

PostPosted: Thu Feb 14, 2013 10:24 am    Post subject: Reply with quote

Have a similar problem, but had used an administrator account to install and setup the note pager pro on the c: drive as recommended by support with %LoginName% for the receiver for all users. These machines are on Active Directory network. This works fine on the old XP machines that are already on the AD.

I installed it on a machine without AD (one of the other replacements not finished yet) and it seems to work. It had a registry section that the other AD machines are missing. Computer\HKLM\Software\NotePage\NotePagerPro\. I tried added this section to the three new machines on AD.

On the AD machines, I found that their registry settings are in the HKEY Current user section under VirtualStore\Machine\Software\NotePage\NotePagerPro\

These pages need to go out for all users and causing issues. Any ideas on how to solve this? Thanks in advance.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Thu Feb 14, 2013 10:39 am    Post subject: Reply with quote

What operating system are you using?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
murraye



Joined: 14 Feb 2013
Posts: 5
Location: Pittsburgh

PostPosted: Thu Feb 14, 2013 10:41 am    Post subject: Reply with quote

Tech Support wrote:
What operating system are you using?


Windows 7 Enterprise 32-bit.


Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Thu Feb 14, 2013 10:44 am    Post subject: Reply with quote

When installing in Windows 7, there are a few hoops you have to jump through in order for everything to function properly for all users. When you install, be sure to use these installation steps to authorize the program via the UAC:

http://www.notepage.net/videos/notepager-pro-vista-installation.htm

During the installation, change the installation directory from c:\Program Files\NotePager Pro\ to c:\NotePager Pro\

The Program Files directory is virtualized in Windows Vista, Windows 7 and Windows 8, meaning that each user gets their own unique instance of the Program Files directory. While this may not present a problem for direct use of the program, the virtualization extends to the registry as well, which is the cause of the Sender's Name issue you're running in to. So, if you use the UAC verified installation and install to the root rather than the Program Files directory, the issue should go away.



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
Tech Support



Joined: 25 Aug 2003
Posts: 4041

PostPosted: Thu Feb 14, 2013 10:53 am    Post subject: Reply with quote

Hmm... interesting. When you go to the Tools - Settings - General, is the option "Save Settings for All Users" selected? If so, if you go to the HKEY_LOCAL_MACHINE - Software - NotePage - NotePager Pro section of the registry, is the Sender value set to what you have it set to in the program?

Also, if you log on as one of the users where the Sender's Name isn't propagating appropriately, what option and value to they have selected?



_________________
Tech Support
support@notepage.com
http://www.notepage.net
Back to top
View user's profile
murraye



Joined: 14 Feb 2013
Posts: 5
Location: Pittsburgh

PostPosted: Thu Feb 14, 2013 11:25 am    Post subject: Reply with quote

All Users was selected when I saved the setting.

I believe Blank field was shown. I redid the setting under an Administrator account and restarted the computer, but did not have another user to test with yet.

I had to add that section of the registry to HKLM\Software\NotePage\NotePagerPro, but it does show Sender as %LoginName% now. I checking permissions of that key section and added everyone to it.


Back to top
View user's profile
Display posts from previous:   
Post new topic   Reply to topic    NotePage, Inc. Forum Index -> NotePager Pro Support All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2002 phpBB Group
Theme created by Vjacheslav Trushkin